Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#27 closed defect (fixed)

shptree crashes with an error message ("The ordinal 4444 could not be located in the dynamic link library \ms4w\Apache\cgi-bin\libcurl.dll")

Reported by: Bjoern Owned by: Jeff McKenna
Priority: blocker Milestone: 3.1.2 release
Component: MS4W - Tools Version: 3.1.0
Keywords: shptree libcurl.dll ordeal 4444 Cc:
Blocked By: Blocking:

Description

The libcurl.dll is in the directory.

I have no idea what to do. The System is a Microsoft Windows 8.1 x64 Enterprise edition.

I have linked my versions of shapetree and libcurl.dll to the ticket.

Attachments (1)

test.txt (4 bytes ) - added by Jeff McKenna 6 years ago.
testing

Download all attachments as: .zip

Change History (11)

comment:1 by Bjoern, 6 years ago

Sorry I fail to link any files to the ticket.

Trac states IndexError: Pop from empty list

I have allowed popups in the browser just for the Chance that this might be the Problem. nada

by Jeff McKenna, 6 years ago

Attachment: test.txt added

testing

comment:2 by Jeff McKenna, 6 years ago

I cannot reproduce on any machines.

Can you verify that there is not another "libcurl.dll" somewhere else on your system?

Also, do the same for the files "libeay32.dll" and "ssleay32.dll".

I bet there is a conflict somewhere with an external lib.

comment:3 by Bjoern, 6 years ago

Hi jmckenna,

thank you very much for your Support. The libcurl.dll is only in the path of ms4w.
I have installed a rather new Version of postgres (9.4) lately and they do have newer Versions of the libeay32.dll and the ssleay32.dll!

C:\Program Files\PostgreSQL\9.4\bin\libeay32.dll		1,50 MB (1.582.592 Bytes)	Freitag, ‎10. ‎Juli ‎2015
C:\Program Files\PostgreSQL\9.4\bin\postgisgui\libeay32.dll	1,50 MB (1.581.056 Bytes)	Dienstag, ‎7. ‎Juli ‎2015
C:\ms4w\Apache\cgi-bin\libeay32.dll				1,20 MB (1.259.520 Bytes)	‎Montag, ‎17. ‎August ‎2015
C:\ms4w\Apache\bin\libeay32.dll					1,20 MB (1.259.520 Bytes)	‎Montag, ‎17. ‎August ‎2015


C:\Program Files\PostgreSQL\9.4\bin\ssleay32.dll		342 KB (350.720 Bytes)	‎Freitag, ‎10. ‎Juli ‎2015
C:\Program Files\PostgreSQL\9.4\bin\postgisgui\ssleay32.dll	340 KB (348.160 Bytes)	Dienstag, ‎7. ‎Juli ‎2015
C:\ms4w\Apache\cgi-bin\ssleay32.dll				289 KB (296.448 Bytes)	Montag, ‎17. ‎August ‎2015
C:\ms4w\Apache\bin\ssleay32.dll					289 KB (296.448 Bytes)	Montag, ‎17. ‎August ‎2015

How should I proceed? I do need postgres and I have after many days sucessfully importet planet-latest so I do not like the idea of ruining anything there?

There is no other libcurl.dll on my drive ...

comment:4 by Bjoern, 6 years ago

Just as further Information:

I have copied libeay32.dll and ssleay32.dll from postgres to the Apache directories ... it did not work :-( (same error)

So I have restored my backups again. Any idea what to try next?

comment:5 by Jeff McKenna, 6 years ago

delete (rename to ".bad") all non-MS4W libeay32.dll and ssleay32.dll copies on your machine (if postgres has one, rename the file), then install a fresh MS4W on that machine and retry. Do not copy external files into MS4W (never do this).

Your issue is for sure due to an external library dll (from postgres or qgis etc) being loaded by accident.

comment:6 by Jeff McKenna, 6 years ago

comment:7 by Jeff McKenna, 6 years ago

Milestone: 3.1.0 release3.1.2 release

comment:8 by Jeff McKenna, 6 years ago

Please test this issue on a fresh machine, with today's MS4W 3.1.2 release: http://ms4w.com

I also test on a Microsoft Windows 10 x64 Enterprise edition

comment:9 by Jeff McKenna, 6 years ago

Resolution: fixed
Status: newclosed

no feedback, closing.

comment:10 by Jeff McKenna, 3 years ago

Possibly a good time to test with a recent MS4W: https://www.ms4w.com/release/ms4w-3.2.7-setup.exe

Note: See TracTickets for help on using tickets.