Opened 5 years ago

Closed 5 years ago

#132 closed defect (fixed)

imageObj::saveWebImage(): [MapServer Error]: jpeg_ErrorExit(): libjpeg: Backing store not supported

Reported by: Stefan Schmidhammer Owned by: Jeff McKenna
Priority: major Milestone: 3.2.3 release
Component: MS4W - PHP Version: 3.2.2
Keywords: libjpeg, jpg, jpeg, Backing store, jpeg_ErrorExit Cc:
Blocked By: Blocking:

Description

I have installed MS4W on Windows 7 x64 and always when I try to output a map as JPEG I get the error:

imageObj::saveWebImage(): [Map Server Error]: jpeg_ErrorExit(): libjpeg: Backing store not supported

Only when I set the SIZE in the mapfile to a very small dimension like
SIZE 10 10
a JPEG gets successfully produced which is around 350KB
Even if I set it to SIZE 15 15 it fails with that error.

Based on some researched it seems this is some memory limit in the JPEG library, however I don't see where I can change this. It should be possible to create bigger pictures than 10x10 by default.

So far I have to create PNG files where this error does not occur.

Header of mapfile:

NAME testmap.map
STATUS ON
IMAGETYPE JPEG
IMAGECOLOR 240 240 240
SHAPEPATH "shp/"
FONTSET "fonts/fonts.list"
EXTENT -1200 -900 400 100
SIZE 500 500
UNITS METERS

Change History (5)

comment:1 by Jeff McKenna, 5 years ago

Can you create a small test case for this (tiny mapfile with 1 layer, remove references to symbolsets, labels etc, and include a small source dataset or use an inline FEATURE object for your data http://mapserver.org/input/vector/inline.html) and paste the url here in the ticket so I can download and test locally here? thanks. -jeff

comment:2 by Jeff McKenna, 5 years ago

@Terra you can ignore that request, I made a test case as requested myself, and can reproduce locally. https://www.gatewaygeomatics.com/dl/ticket-132-jpeg.zip

comment:3 by Jeff McKenna, 5 years ago

Update: this issue required a fix to both the GDAL and MapServer source code, to handle newer libjpeg-turbo library versions:

Please test with the new MS4W-3.2.3-beta and report back here if all is now ok: https://www.ms4w.com/release/experimental/ms4w_3.2.3-beta1.zip Thanks for reporting this.

comment:4 by Jeff McKenna, 5 years ago

Milestone: 3.2.2 release3.2.3 release

comment:5 by Jeff McKenna, 5 years ago

Resolution: fixed
Status: newclosed

The issue is fixed, and included in today's MS4W 3.2.3 release. https://ms4w.com

Note: See TracTickets for help on using tickets.